VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

  #1  
Old 09-15-2021, 10:42 PM
stringbender stringbender is offline
 
Join Date: Dec 2020
Location: stuart, fl
Posts: 28
Default light speed on left, slick on right

Recently purchased RV6A, high CHT's, it appears to be a difficult to time the light speed standing in the cockpit and using a timing light. Anyone accomplished that?

The right mag is a slick and it makes the clicking sound for impulse coupling.
The engine has an intermittent bump when hot usually around take off. I am contemplating removing the slick all together, I just don't have any records of the mag. Also the engine runs so well on the light speed I am thinking its doing all the work, and including retard spark for start?

What mag would be a good combination (not adding another battery)?
Reply With Quote
  #2  
Old 09-16-2021, 06:50 AM
Carlos151's Avatar
Carlos151 Carlos151 is offline
 
Join Date: Jan 2008
Location: Lebanon, TN
Posts: 464
Default Plasma III and E-mag

I run a Plasma III for the top plugs and replaced my Slick impulse mag at about 350 hours with an E-mag for the bottom plugs. That combination works great for me. E-mag is super easy to time and I agree the Plasma is a bit tougher but once you get it timed I have found zero drift over the last 6 years. With that combination I'm seeing 170 KTAS running 23/23 and burning 8.1 GPH LOP. Before replacing the mag I was at 8.4 GPH so there was a slight improvement on the gas mileage.
__________________
Karl Richcreek
RV-8
N151TK "La Otra Chica"
Flying as of August 14, 2015
TN26
Build Log
Reply With Quote
  #3  
Old 09-16-2021, 09:18 AM
Carl Froehlich's Avatar
Carl Froehlich Carl Froehlich is offline
 
Join Date: Dec 2007
Location: Dogwood Airpark (VA42)
Posts: 3,581
Default

You must verify the timing of the Lightspeed with a light. This is a two person job, donít try it by yourself. The second person stands forward of the wing to do this.

I found an RV-7 with dual Lightspeed with CHT from day one running 400+ no matter what. Verified install correct. The timing light showed that both ignitions where stuck on full advance (close to 40 degrees) no matter what the engine was doing. They finally went back to Klaus for repair.

I run dual pMags, and recommend that setup.
Carl
Reply With Quote
  #4  
Old 12-31-2021, 04:21 PM
stringbender stringbender is offline
 
Join Date: Dec 2020
Location: stuart, fl
Posts: 28
Default

I have resolved the high CHT issues. Re-jetting the carburetor , fixing the cowl, baffle rubber replaced.

The pressure sensor on the Lightspeed is critical to the performance, if failed the timing goes full advanced.

I had to use an old timing light, stood up in the cockpit, thanks to a slider and use reflective tape on the backside of the ring gear to highlight the timing marks. Everything is fine now and I love that light speed. Engine starts like a car.
Reply With Quote
  #5  
Old 12-31-2021, 06:11 PM
scsmith scsmith is offline
 
Join Date: Jan 2008
Location: Ashland, OR
Posts: 3,059
Default

I have a lightspeed on the left and a slick mag on the right. I start on the lightspeed only. The mag is not impulse coupled.

If the base timing on the Lightspeed is more advanced than the mag, you will have higher CHT and will have the feeling the mag isn't doing much.

I'm not convinced on your comment about the MAP sensor failure causing full advance. Perhaps it depends on how the sensor fails, but if it goes to zero output, or if you open the pressure line to it, the Lightspeed will go to the base timing - no advance.
__________________
Steve Smith
Aeronautical Engineer
RV-8 N825RV
IO-360 A1A
WW 200RV
"The Magic Carpet" Flying since Sept. 2009
Hobbs 700
also
1/4 share in 1959 C-182B (tow plane)
LS6-15/18W sailplane SOLD
bought my old LS6-A back!!
VAF donation Dec 2021
Reply With Quote
  #6  
Old 12-31-2021, 10:32 PM
Toobuilder's Avatar
Toobuilder Toobuilder is offline
 
Join Date: Jul 2009
Location: Mojave
Posts: 4,897
Default

There are some well documented examples of lightspeed MAP failure = full advance on this forum. Its one of the reasons I program my SDS ignition to default to base timing at the extreme ends of the MAP range. Both SDS and lightspeed use the similar GM style MAP logic.
__________________
WARNING! Incorrect design and/or fabrication of aircraft and/or components may result in injury or death. Information presented in this post is based on my own experience - Reader has sole responsibility for determining accuracy or suitability for use.

Michael Robinson
______________
Harmon Rocket II -SDS EFI
1940 Taylorcraft BL-65
1984 L39C - SOLD
RV-8 - SDS CPI - SOLD
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 02:26 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.