VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

Prev Previous Post   Next Post Next
  #1  
Old 01-13-2022, 12:21 PM
74-07 74-07 is offline
 
Join Date: Dec 2016
Location: Greenville, SC
Posts: 665
Default EMS D-10 Kavlico sensor question

I am just wrapping up doing a VFR panel upgrade to our RV-8 which involved installing a used Dynon EMS D-10. Today, we cranked it for the first time and everything is perfect except the fuel pressure. I ordered and installed the newest Kavlico sensors and, as I understand it, the 150 psi version is used for both oil and fuel pressure (IO-360 angle valve). That's what I installed. I have updated the unit to the latest software version and selected sender type 7. The problem is that the fuel pressure reads about one third of normal (10 psi versus 30 psi). I called Dynon and they said I have to get the 50 psi Kavlico but that seems to contradict everything I read. What am I missing?
Attached Thumbnails
Click image for larger version

Name:	AC8137A0-7085-4C00-BC4A-48E5ECAE52B8.jpg
Views:	62
Size:	330.2 KB
ID:	20936  
__________________
RV-8 sold
RV-7 sold
RV-8 flying
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 08:41 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.