VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

Prev Previous Post   Next Post Next
  #1  
Old 01-22-2022, 05:54 PM
Sdemeyer Sdemeyer is offline
 
Join Date: Apr 2015
Location: Olympia,wa
Posts: 52
Default TruTrak Vision 385

Today while taking advantage of the rare nice PNW weather my relatively new TruTrak 385 malfunctioned. "Gyro Set" appeared on the screen for a few seconds, the RV6 started wandering around the sky on its own and I could not shut off the AP without pulling the breaker. The AP disconnect button disconnected the AP for a few seconds but then it reengaged itself with no input from me! This was repeatable so I have to leave the circuit breaker pulled until I figure out what is wrong.

There does not appear to be too much MFG support from Bendix/King for these AP's. I'm not sure what could cause this? It has always worked fine for the last year or so up until now.

Any ideas?

Thanks! Scott
__________________
Scott DeMeyer
Olympia,WA
RV6A quickbuild, Flying as of 10-14-2017
Mustang II Built and Flying
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 02:49 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.